IBM ILMT – Do I Need To Install For Cognos BI, TM1 or Express Environment?

Do I Need to Install for Cognos BI, TM1 or Express Environment?

If you have an IBM support renewal coming up, it is a great time to check the requirements of having the IBM License Monitoring Tool (ILMT) installed to pass an IBM audit.   As a Business Analytics Coach at Lodestar Solutions, I find clients often don’t know they are required to have the ILMT installed.   ILMT is typically required if you have virtualized your environment and have IBM Cognos BI PVU licensing or Cognos Performance Management (TM1).

The IBM License Metric Tool [ILMT] helps you maintain an inventory of the PVU based software deployed for your Full Capacity or Virtualization (Sub-) Capacity environment and it measures the PVU licenses required by software. It is intended to help you manage your IBM software licensing requirements and help you be ready if you get audited. Customers are responsible for supplying hardware and installation services required for installing the tool. It is not part of the software download and not typically installed by IBM partners implementing BI or TM1. It’s up to you to know if you need it and get it installed.

When is the ILMT Needed?

The use of IBM License Metric Tool is recommended by IBM for Full Capacity PVU environments and is mandatory for use with PVU sub-capacity licensing. According to IBM, the following exceptions apply:

  1. When ILMT does not yet provide support for the Eligible Virtualization Environment (In order to be notified when ILMT support for eligible virtualization technologies become available, customers need to subscribe to “My Notifications”.)
  2. If your Enterprise has fewer than 1,000 employees and contractors worldwide, you are not a Service Provider, and you have not contracted with a Service Provider to manage your Eligible Virtualization Environment
  3. If total physical capacity of your servers with an Eligible Virtualization Environment, measured on a Full Capacity basis, but licensed using sub-capacity terms is less than 1,000 PVUs.

For the above exceptions, customers must manually manage, track, and prepare a Manual Calculation of Virtual Capacity worksheet for each server. For more details about the requirements for this worksheet, you can go to Virtualization Capacity License Counting Rules or use the Manual Calculation of Virtual Capacity worksheet available from the right hand navigation bar.” See

ILMT not Required for Cognos Express 10.2.2

*Note: If you have Cognos Express, IBM announced with 10.2.2 a maximum limitation of 1600 PVUs for the ICAS (TM1) Server and no need for the ILMT tool.

Where do I get the ILMT?

A quick way to see if you already have the ILMT tool is to check your IBM entitlements. It should show up as a part number that’s free. If you determine you need the ILMT installed and don’t have it, you must first order it but remember that there is no cost. This link will take you to a place you can order it:

ILMT helpTwo versions of ILMT are available – version 7.5 of ILMT was announced on December 13, 2011 via Software Announcement 211-329 and version 9.2 of ILMT announced on March 17, 2015. Customers have 90 days from first eligible Virtualization (Sub)-capacity product deployment to install and begin using ILMT for supported virtualization technologies. New ILMT customers can install either V7.5 and/or V9.2 depending on the operating system and virtualization environments supported by each release.

The ILMT team has a Youtube channel with a number of informative videos if you need information on installing the ILMT:

So go check if you need the ILMT or if you have it installed. If you have licensing questions, please contact me at We would be happy to provide a license review with a competitive software renewal quote. You can contact our renewal department by emailing us at